Total registered users : 42995 • Last registered User : erik.rojas
SUBJECTS > FORUM UK/US > Hercules Dj Console RMX asio problem
Back to the topics REPLY

Hercules Dj Console RMX asio problem

Nilsie


2 Messages
Posted on 8/9/2013 at 7:59:47 PM
QUOTE
Belgium
Hi,

first of all, I've been working on this for 72 hours now, and I have a certain amount of pc knowledge + I've researched this problem before with my previous setup.

I have a Hercules dj console RMX, which was working fine, but for some reason I had to format my pc.
Now in Virtual DJ it gives the "error in the ASIO soundcard" error.
I have formatted my PC several times now, and always installing RMX software and drivers first then VDJ and only that.
No system updates, no other drivers except my ethernet.

It doesn't matter if I do this with the Hercules RMX or with an ESI U46DJ soundcard. The error remains.
This error is quite frequent, but no one has a solution for it. I've tried disabling the windows GW synth, I've disabled every sound option, I made sure RMX wasn't default sound, then I made sure it was the default sound.
I have checked and unchecked the exclusive mode in sound options, but still nothing.
I've formatted my PC after removing my SB audagy sound card, also removed my nvidia video card.
I've removed every non standard hardware from my pc, I have tried all 9 USB ports, each one after a clean format.
This is getting real annoying because formatting over 15 times is pretty time consuming.

I hope someone has something I'm not seeing this time, since last time I got it to work on exactly the same system, with exactly the same OS, Windows 7. 

Grtz, a very frustrated person who can't mix with his TC vinyls. 

Maxdjack


1134 Messages
Posted on 8/15/2013 at 11:43:12 AM
QUOTE
Canada
  • DJConsole RMX2
  • DJ Console Rmx
  • Djuced®
  • Traktor®
  • VirtualDJ®
  • MixVibes Cross®
  • DJay®
Hello Nilsie,


1) You should precise
- the VirtualDJ software you use: is it VirtualDJ Pro 7 or is it VirtualDJ 5 Rmx edition, and precise in details which version you use (for example VDJ Pro 7.4),
- the DJ Console Rmx driver you use (the driver version is listed in Rmx About panel),
- the Windows 7 version you use (32-bit or 64-bit, service pack 1 or not).

2) If you use VirtualDJ 7 Pro (as I suspect since you mention TC vinyls):
a - please confirm you set your Rmx in ASIO mode (not in WDM) in Rmx control panel before running VirtualDJ DJ Pro


b- confirm you select Rmx in ASIO in VirtualDJ sound setup menu




Answering to technical questions with
- more technical details than needed is NEVER a problem,
- less technical details than needed is ALWAYS a problem
.

Nilsie


2 Messages
Posted on 8/18/2013 at 6:07:46 AM
QUOTE
Belgium
Thanks for the reply.

The precise info:
- Virtual dj pro 7 and the RMX edition, tried both, now only using Pro 7.02
-The DJ console RMX drivers 2009 and 2013 both tried, now on 2013 HDJS.
-Windows 7 X64, tried without SP1, now updated to SP1, and still not working.

The panel used to work, setting itself from WDM to ASIO whenever needed. Also my previous settings wasn't selecting the ASIO driver, but just the Hercules RMX as default. This was how it worked last time at least.
Anyhow, it still doesn't work using your help, but everyday I keep troubleshooting for 2 hours, which is getting annoying.
I feel like I've tried everything 10 times already and am suffering from no music mixing withdrawal...
Maybe I should just install windows XP just to run virtual DJ.


EDIT: When starting VDJ with ASIO -> Hercules RMX, it gives the error but doesn't switch back to WDM.
When using the Hercules RMX instead of ASIO, it does switch back to WDM after the error and when launching VDJ it tries switching to ASIO, but then just returns and give an error.

 

Maxdjack


1134 Messages
Posted on 8/20/2013 at 12:15:22 PM
QUOTE
Canada
  • DJConsole RMX2
  • DJ Console Rmx
  • Djuced®
  • Traktor®
  • VirtualDJ®
  • MixVibes Cross®
  • DJay®
Hello Nilsie,

If you get also an ASIO error when using ESI U46DJ, it is not an error of VDJ selecting Rmx ASIO, it looks like a general error in ASIO on your computer.

Did you install a dedicated version of ASIO4ALL, for example ASIO4Typhoon, on your computer?
I did it a few years ago and no ASIO worked again on the computer, and I had to uninstall this defective ASIO4Typhoon, not only with Windows 7 program uninstallation, but I had to use regedit to manually remove all the entries of this ASIO4Typhoon software, which is pretty surprising because the regular ASIO4ALL is OK.


Answering to technical questions with
- more technical details than needed is NEVER a problem,
- less technical details than needed is ALWAYS a problem
.